龙岩易富通网络科技有限公司

龙岩小程序开发,龙岩分销系统

centos5.4中安装node js(错误fpu = 'vfpv3' if armv7 else 'vfpv2'的解决)

2016.08.05 | 1310阅读 | 0条评论 | 服务器配置

1、下载nodejs

wget http://nodejs.org/dist/v0.10.10/node-v0.10.10.tar.gz


2、升级CentOS 5.6 64位版python到2.7.3

原因是CentOS 5.6自带的Python版本是2.4.3,但是目前许多基于Python的应用软件要求的Python版本应要高于2.4(如iotop、nodejs、func 等要求Python版本至少是2.6以上)


wget -c http://www.python.org/ftp/python/2.7.3/Python-2.7.3.tar.bz2

tar jxvf Python-2.7.3.tar.bz2

cd Python-2.7.3

 

./configure 

make && make install

 

自此,python2.7安装后路径默认是在/usr/local/lib/python2.7

查看Python版本:

/usr/local/bin/python2.7 -V


但是注意:

正常情况下即使python2.7安装成功后,系统默认指向的python仍然是2.4.3版本,考虑到yum是基于python2.4.3才能正常工作,不敢轻易卸载。如何实现将系统默认的python指向到2.7版本呢?


3、如果不进行第二步的安装python的2.6版本以上3.0版本以下,会出现错误:

[root@localhost nodeJs]# cd node-v0.10.10

[root@localhost node-v0.10.10]# ./configure 

  File "./configure", line 434

    fpu = 'vfpv3' if armv7 else 'vfpv2'

                   ^

SyntaxError: invalid syntax


4、编译安装nodejs

tar zxvf node-v0.10.0.tar.gz

cd node-v0.10.0

./configure

make


在make的时候汇报错误:

import bz2 ImportError: No module named bz2 的错误,这说明缺少bz2

安装bz2

yum -y install bzip2*

进入python目录,然后再编译一次python,然后再安装nodejs


然后执行

cd node-v0.10.0

./configure

make

make install


赞 (

发表评论