龙岩易富通日常工作笔记

记录日常工作中的点点滴滴

NPM下载出错 npm ERR! Error: No compatible version found

2016.08.08 | 703阅读 | 0条评论 | node.js

如果在Linux系统中,通过一条命令更新npm可以解决。


首先我们查看一下npm当前版本,打开cmd

运行指令

npm -v

 

如果不是最新版本,运行一下代码即可。

运行指令

npm install -g npm

这样npm就更新到最新版本了。

 

如果想更新到指定版本,

运行指令

npm -g install npm@2.9.1

(@后跟版本号),

这样我们就可以更新npm版本了。


在Window环境中,必须升级NPM到1.4.10以上的版本,我重新安装了node-v0.10.31-x64.msi,对应的NPM为1.4.23,再此运行npm install命令,依赖包下载运行正常。

升级后的系统环境

Win7 64bit

Node 0.10.31

NPM 1.4.23

下载依赖包,运行正常。


赞 (

发表评论